Back to overview
Degraded
Issues accessing Microsoft 365 services on campus
Nov 20 at 03:13pm GMT
Affected services
Intranet
Microsoft Teams
Network and Internet
Resolved
Nov 21 at 10:04am GMT
Starting around 15:00hrs until 16:12 on 20/11/2023 our network provider experienced a blocklist issue, causing all requests to be blocked. The service has been returned and Jisc are now looking into the root cause of the issue.
Affected services
Network and Internet
Microsoft Teams
Intranet
Created
Nov 20 at 03:13pm GMT
We’re investigating an issue with Network and Internet services impacting users on campus. We’re working to fix the problem as quickly as we can. We’ll share another update shortly.
Affected services include, SharePoint Online and Microsoft Teams.
Affected services
Network and Internet
Microsoft Teams
Intranet