Back to overview
Downtime
Issue with SEATS Portal
Oct 07, 2025 at 03:49pm UTC
Affected services
SEAtS
Resolved
Oct 08, 2025 at 08:25am UTC
The issue has been resolved by SEATS Support
Affected services
Created
Oct 07, 2025 at 03:49pm UTC
There is currently an issue with accessing the SEATS portal. We've contacted the vendor and are currently waiting for them to resolve the issue
Affected services