Back to overview
Degraded
Network Connectivity Issues on campus
Jun 27 at 03:23pm BST
Affected services
Network and Internet
Resolved
Jun 27 at 03:28pm BST
We've identified the faulty network router and have taken it out of service.
Network performance is now stable, and we're continuing to monitor the situation.
Incident Start Date and Time
Friday, June 27, 2025, at 15:00 BST
Incident End Date and Time
Friday, June 27, 2025, at 15:20 BST
Affected services
Network and Internet
Created
Jun 27 at 03:23pm BST
Users on campus may experience intermittent or complete loss of network connectivity, impacting both wired and wireless connections. This may result in an inability to access internal resources, the internet, and other network-dependent services.
Affected services
Network and Internet