Back to overview
Degraded

We're currently investigating Wi-Fi performance issues across campus

Jun 24 at 10:33am BST
Affected services
Network and Internet

Resolved
Jun 25 at 09:30am BST

We identified a routeing issue and put a work-around in place. Normal service has now been restored.

Updated
Jun 24 at 12:12pm BST

We believe we've found an issue that may have been causing slow loading of web pages and other timeouts. We have implemented a workaround.

Affected users should try disconnecting from the WiFi (turn wifi off and on again on your device) and reconnect.

Created
Jun 24 at 10:33am BST

We're currently investigating Wi-Fi performance issues across campus