Back to overview
Degraded
Power BI Reports Not Refreshing
Dec 18 at 05:47pm GMT
Affected services
Power BI Dashboards
Resolved
Dec 19 at 12:06pm GMT
We’re back! Power BI Reports should be up and running. Thanks for bearing with us.
Affected services
Power BI Dashboards
Created
Dec 18 at 05:47pm GMT
There are ongoing issues affecting Power BI Reports and they are currently not refreshing. The Data Team is investigating and an update will be shared as soon as service is restored.
Affected services
Power BI Dashboards