Back to overview
Degraded

Users cannot find the Regent's University London app in the Google Play store

Nov 29 at 01:06pm GMT
Affected services
Regent's App

Resolved
Jan 13 at 11:18am GMT

We have identified the root cause of the issue. The Regent's app should now be visible in the Android Play Store.

Created
Nov 29 at 01:06pm GMT

We are aware that users are unable to to locate the Regent's University London app in the Google Play store. We're working with Google to fix the problem as quickly as we can.