Back to overview
Degraded

Power BI service degradation

Aug 19 at 03:45pm BST
Affected services
Power BI Dashboards

Resolved
Aug 20 at 08:41am BST

Microsoft have identified the root cause of the issue. They have completed the rollback of the update to the most recent working version and have confirmed the impact has been successfully remediated.

Created
Aug 19 at 03:45pm BST

Users may have issues accessing Power BI or data may not be updated as frequently as expected.