Issues with accessing multiple Microsoft 365 services
Resolved
Jul 30 at 08:54pm BST
Microsoft have confirmed that the mitigation approach is successfully addressing the remaining impact. They are applying these changes in the final regions and will continue to monitor service health to ensure the issue is fully resolved once completed.
Affected services
Microsoft Teams
Email & Calendar
Power BI Dashboards
Updated
Jul 30 at 03:45pm BST
Microsoft have made a change to their network settings to help improve Microsoft 365 services. As a result, some of these services are now using backup paths to keep running smoothly. Their monitoring shows that things are getting better, and they are keeping an eye on everything to make sure it fully recovers.
Affected services
Microsoft Teams
Email & Calendar
Power BI Dashboards
Created
Jul 30 at 02:10pm BST
Users may be unable to access multiple Microsoft 365 services.
Users who are able to access Microsoft 365 service may experience latency or degraded feature performance.
Affected services
Microsoft Teams
Email & Calendar
Power BI Dashboards