Back to overview
Degraded
There is currently an issue with emails being sent from on-premise services and distribution lists
Jul 25 at 02:14pm BST
Affected services
Email & Calendar
Resolved
Jul 25 at 04:42pm BST
This has now been resolved and all email should now be flowing as expected.
Affected services
Email & Calendar
Created
Jul 25 at 02:14pm BST
We are working to put a fix in place.
Affected services
Email & Calendar