Email to Distribution Lists may be failing to send
Resolved
Oct 25 at 01:07pm BST
We have identified the root cause of the secondary issue. Full Email functionality should have been restored by 12:26. Thanks for your patience!
Affected services
Email & Calendar
Updated
Oct 25 at 11:39am BST
Unfortunately this issue has reoccurred. We’re working to fix the problem as quickly as we can. We’ll share another update shortly.
Affected services
Email & Calendar
Updated
Oct 24 at 04:14pm BST
We’re back! Email to Distribution Lists should be up and running. Thanks for bearing with us.
Affected services
Email & Calendar
Created
Oct 24 at 03:46pm BST
We’re having some trouble with Email. We’re working to fix the problem as quickly as we can. We’ll share another update shortly.
Affected services
Email & Calendar